読者です 読者をやめる 読者になる 読者になる

monaurallab

モノラルラボ

php の古いバージョンで死にかけた、4.1.0より古いと $_SERVER とかつかえない

php

こないだ担当した案件で使ってたサーバ、php のバージョンが 4.0.8 というなかなかに古いものだった。気づかずふつうにプログラム作ってたら、いざアップしようとした時にぜんぜん動かなくてまあたいへん。

$_SERVER とかが使えるのは php 4.1.0 から!
それ以前のバージョンではは $HTTP_SERVER_VARS を使わないといけません!(しかもスーパーグローバルじゃないよ!)

そこんとこうっかりしてたので、自分用にメモです。

http://docs.php.net/manual/ja/reserved.variables.server.php