everybodyworks

マツオ (matsuoshi) のざっくりしたブログです

Netlify 上で使う Hugo のバージョンを指定する

このブログは Netlify + Hugo で作っております。

で、いま Netlify にデフォルトで入っている Hugo のバージョンは 0.17 なのですが、Hugo の最新バージョンは 0.25.1 でして、けっこうな開きがあるんですね(2017/07時点)。テンプレート選びとかにもバージョンの違いは影響してくるんですが、これはもう Netlify 使っている以上しょうがないのかなあ、と思っていました。

しかししかし。簡単な設定ひとつで、 Netlify でも最新バージョンの Hugo が使えるとは……

qiita.com

……なんと……

Netlify の設定画面で、こんな感じで環境変数1つ追加するだけ。これだけでいいんすね。

f:id:matsuoshi:20180425180905p:plain

実際、吐き出されたコードの meta タグ見てもこんな形で入っています。

<meta name="generator" content="Hugo 0.25.1" />

ありがたやありがたや。

公式サイトでもしっかり方法が紹介されていました。

www.netlify.com

すばらしい。